Back to overview
Degraded

Cloudjet Console Interruption

Mar 6, 2026 at 6:24pm UTC
Affected services
cPanel Hosting
Firewall Server

Resolved
Mar 7, 2026 at 5:06am UTC

Incident has been resolved.

Created
Mar 6, 2026 at 6:24pm UTC

We are currently experiencing degraded performance from some of our upstream hosting partners, which may result in an increased number of 503 (Service Unavailable) responses and could temporarily affect access to certain Cloudjet services.

Please note that Cloudjet Protected Servers (Windows and Linux) remain fully operational and are not impacted by this issue.

Our team is actively working with the affected providers to restore normal performance as quickly as possible.

We appreciate your patience and understanding.